ターミナルに出るWarning: Use php@7.1 instead of deprecated php71の解決法

最終更新日

Comments: 0

macでhomebrewを使ってる中で、ターミナル立ち上げるたびに最近こんなエラーが出続けて困っていたので貼っておきます

Warning: Use php@7.1 instead of deprecated php71

翻訳かければ一発ですが、php71はもう廃止されるのでphp@7.1を使って下さいねっていう意味です。

要はpath指定先を変えればいいので、.bashrc.bash_profile (別のshell使っている人は相当する設定ファイル)に書かれている

PATH="${PATH}:$(brew --prefix homebrew/php/php71)/bin"

という記述を

PATH="${PATH}:$(brew --prefix homebrew/core/php@7.1)/bin"

このように置き換えてsource .bashrcみたいな感じで反映させればOKなはずです。

都内でエンジニアやってます 趣味で色々開発しつつのんびりと生活してます

シェアする

コメントを残す

%d人のブロガーが「いいね」をつけました。